vSphere 6.7 Client Plugin Readiness

vSphere 6.7 Client Plugin Readiness

This post was originally published on this site ---

       

The vSphere client team has been actively working with VMware partners to provide compatible plugins in the vSphere HTML5 Client and vSphere Web Client (Flex-based).  vRealize Operations 6.7, Site Recovery Manager 8.1, and vSphere Replication 8.1 have already released with standalone HTML5 clients providing similar functionality to their vSphere Flex client plugins.  Other VMware solutions are targeting fully featured vSphere HTML5 client plugin availability by Fall 2018, including Virtual SAN and vSphere Integrated Containers.

A number of you have asked about NSX in the vSphere HTML5 Client.  NSX 6.4.1 released in May 2018 with enhanced vSphere HTML5 Client plugin functionality and is compatible with vSphere 6.7, vSphere 6.5 Update 1 and later, and vSphere 6.0 Update 2 and later.  For more details, see NSX 6.4.1 release notes.  Prior to version 6.4.1, NSX 6.4.0 released in January 2018 with a vSphere HTML5 client plugin, which is compatible with vSphere 6.0 (Update 2 and later), and vSphere 6.5 (Update 1 and later).

Non-VMware solution providers are also developing plugins for the vSphere HTML5 Client and the vSphere Web Client (Flex), and timelines vary depending on the vendor.  We are working closely with the most commonly used vSphere client plugins. Here are the vendors who have committed to delivering plugins compatible with the vSphere 6.7 client (date estimates are subject to change):

  • Dell EMC RecoverPoint: H2 2018
  • Dell EMC Virtual Storage Integrator 7.3.3: compatible with the vSphere 6.7 client
  • Dell EMC Enterprise Storage Analytics 4.5 for vRealize Operations: compatible with the vSphere 6.7 client
  • Veeam: Q3 2018
  • NetApp SnapCenter: Q1 2019
  • Veritas NetBackup: Q3 2018
  • HPE OneView: Q2 2018
  • Fujitsu Eternus: Q2 2018
  • Hitachi Unified Compute Platform Advisor: Q3 2018 (Flex client plugin), Q4 2018 (HTML5 client plugin)
  • Oracle: committed to vSphere 6.7 client compatibility, timeline TBD
  • StorMagic: committed to vSphere 6.7 client compatibility, timeline TBD.  For more details, please create a StorMagic support request on www.stormagic.com

A list of vendors and plugins which have been certified for the vSphere 6.5 and vSphere 6.7 clients can be found in the VMware Compatibility Guide.

For more information on the fully featured vSphere HTML5 Client, check out this related blog post.

If you have comments or questions about specific vSphere client plugins and functionality you need to operate in the vSphere HTML5 Client, please let us know by completing this 2-minute survey.  You can also reach the vSphere client extensibility team at [email protected].

 

Yiting Jin, VMware vSphere Product Management

Prathima Vadiraja, VMware Ecosystem Services

The post vSphere 6.7 Client Plugin Readiness appeared first on VMware vSphere Blog.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.