ALERT: Do not upgrade to VMware vSphere 5.1 if you are using VMware View 5.1.1 or older!

ALERT: Do not upgrade to VMware vSphere 5.1 if you are using VMware View 5.1.1 or older!

If you have VMware View 5.1.1 or older running, do not upgrade to the new release of vSphere 5.1.

Currently there are NO VERSIONS of View which support VMware vSphere 5.1. As a general rule, support for a new version of vSphere takes a new release of View. It was thought that View 5.1.1 might support vSphere 5.1 but a bug was found during testing and stopped this.

If VMware View 5.1.2 is released with vSphere 5.1 support you’ll be ready for the upgrade and if vSphere is patched first you should hopefully be on a supported version. Best of both worlds.

At the moment, VMware recommends to install VMware View 5.1.1 in constellation to VMware vSphere 5.0U1 latest build.

Be careful on production systems!

 

UPDATE: VMware released a KB Article today: vSphere 5.1 is not compatible with any versions VMware View (2035268).

UPDATE2: VMware released last night (2012-10-25) an updated version of vCenter Server (5.1.0a) and also a patch for ESXi to support VMware View 5.1! You can also download the already patched version of ESXi from my.vmware.com

Detailed informations about that can you find here:

KB 2035268 – kb.vmware.com/kb/2035268 – “vSphere 5.1 compatibility with VMware View”

KB 2034548 – kb.vmware.com/kb/2034549 – “VMware ESXi 5.1, Patch Release ESXi510-201210001”

Leave a Reply

Your email address will not be published. Required fields are marked *